Resolved
Internal Services are confirmed stable and no longer impacted. Long term fix has been deployed. Thank you for your patience.
Monitoring
We have applied a fix and are monitoring. At this time the internal services have stabilized. We will continue to monitor while we deploy a long term remediation.
Identified
We have identified an internal service that is having stability issues within the US-EAST-04A cluster (RIC1), This is causing periodic delays in prediction updates. At this time out engineers are aware of the factors causing the instability and are working to allocate more resources to mitigate the delays.