No components marked as affected
Resolved
Our upstream provider has pushed a fix and we have verified that it is working. Please try again if you were having difficulties earlier. Thank you for your patience!
Identified
We are aware of an issue preventing some users from successfully checking out when trying to purchase prepaid credit. We have identified an issue with recent changes from an upstream provider and are in contact with them to resolve the problem. We appreciate your patience as we continue work to fix this.