Billing incorrectly disabled for some customers.
Affected components
Updates

Write-up published

Read it here

Resolved

Incorrectly disabled users have been re-enabled at this time.

Thu, May 22, 2025, 03:16 PM

Identified

We have re-enabled the majority of affected users. We are reviewing all remaining disabled users with an disable event between `2025-05-21 14:40 UTC` and `2025-05-22 13:02 UTC` (window of impact).

Thu, May 22, 2025, 03:05 PM(10 minutes earlier)

Identified

We were alerted that a number of customer's spending was incorrectly disabled due to anti-fraud checks. We have reverted the code that allowed this disabling to happen, additionally, we are in process of re-enabling any incorrectly disabled users.

Thu, May 22, 2025, 02:41 PM(23 minutes earlier)